summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MANIFEST.in11
-rw-r--r--setup.cfg2
-rw-r--r--setup.py1
3 files changed, 13 insertions, 1 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 01aa684..3416a5a 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,7 +1,14 @@
include *.rst
include *.txt
-recursive-include docs *
+include .travis.yml
+include .coveragerc
+include tox.ini
+include bootstrap.py
+include buildout.cfg
+
+recursive-include docs *.rst *.py Makefile make.bat
+recursive-include docs/_static *
recursive-include src *
global-exclude *.dll
@@ -9,3 +16,5 @@ global-exclude *.pyc
global-exclude *.pyo
global-exclude *.so
global-exclude *.class
+
+recursive-exclude docs/_build *
diff --git a/setup.cfg b/setup.cfg
index 0abe01c..3eb334c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -11,3 +11,5 @@ where=src
dev = develop easy_install zope.event[testing]
docs = easy_install zope.event[docs]
+[bdist_wheel]
+universal = 1
diff --git a/setup.py b/setup.py
index af7c1f3..cd948f0 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,7 @@ setup(
+ '\n' +
read('CHANGES.rst')
),
+ keywords="event framework dispatch subscribe publish",
classifiers=[
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",