summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini32
1 files changed, 19 insertions, 13 deletions
diff --git a/tox.ini b/tox.ini
index 6b186ee..0bc7616 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,29 +1,35 @@
[tox]
-envlist =
+envlist =
# Jython 2.7b1 support pending fix for Jython incompat. w/ pip's vendored-in
# requests -> html5 libraries. See
# https://github.com/html5lib/html5lib-python/pull/150
# py27,py33,py34,pypy,pypy3,jython,coverage,docs
- py27,py33,py34,py35,pypy,pypy3,coverage,docs
+ py27,py34,py35,py36,pypy,pypy3,coverage,docs
[testenv]
-commands =
- python setup.py -q test -q
-
-[testenv:coverage]
-basepython =
- python2.7
-commands =
- nosetests --with-xunit --with-xcoverage
+commands =
+ coverage run -m zope.testrunner --test-path=src []
deps =
- nose
+ .[test]
coverage
- nosexcover
+setenv =
+ COVERAGE_FILE=.coverage.{envname}
+
+[testenv:coverage]
+setenv =
+ COVERAGE_FILE=.coverage
+skip_install = true
+commands =
+ coverage erase
+ coverage combine
+ coverage report
+ coverage html
+ coverage xml
[testenv:docs]
basepython =
python2.7
-commands =
+commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =