summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2017-07-11 07:10:59 -0500
committerJason Madden <jamadden@gmail.com>2017-07-11 07:10:59 -0500
commit6146dbb1a7d8c8e1fc6ba084b77ca51bdea91554 (patch)
tree1dc352d1d08d418d28d77b471545fc6d15f87002 /tox.ini
parent903a6621bc05813140c8151112c641df3748d371 (diff)
downloadzope-proxy-6146dbb1a7d8c8e1fc6ba084b77ca51bdea91554.tar.gz
100% coverage
Enable coveralls to report on this. Coverage reports showed two test classes that weren't subclassing the correct base class, so we weren't actually testing the C implementation of `removeAllProxies` and `queryInnerProxy`. Fixing this revealed a probably bug in the implementation of `removeAllProxies`; right now that test is skipped. Also remove the `test_suite` for 'python setup.py test' since it usually doesn't work anymore. See #18.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini51
1 files changed, 22 insertions, 29 deletions
diff --git a/tox.ini b/tox.ini
index 8669b87..fda63e1 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,34 +1,13 @@
[tox]
envlist =
-# Jython support pending 2.7 support, due 2012-07-15 or so. See:
-# http://fwierzbicki.blogspot.com/2012/03/adconion-to-fund-jython-27.html
-# py27,jython,pypy,coverage
- py27,py27-pure,py33,py33-pure,py34,py35,py36,pypy,coverage,docs
+ py27,py27-pure,py34,py35,py36,py36-pure,pypy,coverage,docs
[testenv]
-commands =
- zope-testrunner --test-path=src
deps =
- .[test]
- zope.testrunner
-
-[testenv:py27-pure]
-basepython =
- python2.7
-setenv =
- PURE_PYTHON = 1
- PIP_CACHE_DIR = {envdir}/.cache
-
-[testenv:py33-pure]
-basepython =
- python3.3
-setenv =
- PURE_PYTHON = 1
- PIP_CACHE_DIR = {envdir}/.cache
-
-[testenv:jython]
+ .[test,docs]
commands =
- jython setup.py test -q
+ zope-testrunner --test-path=src
+ sphinx-build -b doctest -d {envdir}/doctrees docs {envdir}/doctest
[testenv:coverage]
basepython =
@@ -39,9 +18,10 @@ commands =
# version, before running nosetests.
pip uninstall -y zope.proxy
pip install -e .
- nosetests --with-xunit --with-xcoverage
+ coverage run -m zope.testrunner --test-path=src
deps =
- .[testing]
+ .[test]
+ coverage
[testenv:docs]
basepython =
@@ -50,5 +30,18 @@ commands =
sphinx-build -b html -d docs/_build/doctrees docs docs/_build/html
sphinx-build -b doctest -d docs/_build/doctrees docs docs/_build/doctest
deps =
- Sphinx
- repoze.sphinx.autointerface
+ .[test,docs]
+
+[testenv:py27-pure]
+basepython =
+ python2.7
+setenv =
+ PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache
+
+[testenv:py36-pure]
+basepython =
+ python3.6
+setenv =
+ PURE_PYTHON = 1
+ PIP_CACHE_DIR = {envdir}/.cache