summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py115
1 files changed, 59 insertions, 56 deletions
diff --git a/setup.py b/setup.py
index 931a6bc..d8b3f5b 100644
--- a/setup.py
+++ b/setup.py
@@ -26,65 +26,68 @@ def read(*rnames):
with open(os.path.join(os.path.dirname(__file__), *rnames)) as f:
return f.read()
+
TESTS_REQUIRE = [
'zope.testing',
'zope.testrunner',
]
-setup(name='zope.tales',
- version='5.0.dev0',
- author='Zope Foundation and Contributors',
- author_email='zope-dev@zope.org',
- description='Zope Template Application Language Expression Syntax '
- '(TALES)',
- long_description=(
- read('README.rst')
- + '\n\n' +
- read('CHANGES.rst')
- ),
- keywords="zope template xml tales",
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: Zope Public License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Natural Language :: English',
- 'Operating System :: OS Independent',
- 'Topic :: Internet :: WWW/HTTP',
- 'Framework :: Zope :: 3',
- ],
- url='https://github.com/zopefoundation/zope.tales',
- license='ZPL 2.1',
- packages=find_packages('src'),
- package_dir={'': 'src'},
- namespace_packages=['zope'],
- python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
- extras_require={
- 'test': TESTS_REQUIRE,
- 'tal': [
- 'zope.tal',
- ],
- 'docs': [
- 'Sphinx',
- 'repoze.sphinx.autointerface',
- 'zope.tal',
- ],
- },
- install_requires=[
- 'setuptools',
- 'zope.interface',
- 'six',
- ],
- tests_require=TESTS_REQUIRE,
- include_package_data=True,
- zip_safe=False,
+
+setup(
+ name='zope.tales',
+ version='5.0.dev0',
+ author='Zope Foundation and Contributors',
+ author_email='zope-dev@zope.org',
+ description='Zope Template Application Language Expression Syntax '
+ '(TALES)',
+ long_description=(
+ read('README.rst')
+ + '\n\n' +
+ read('CHANGES.rst')
+ ),
+ keywords="zope template xml tales",
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Zope Public License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet :: WWW/HTTP',
+ 'Framework :: Zope :: 3',
+ ],
+ url='https://github.com/zopefoundation/zope.tales',
+ license='ZPL 2.1',
+ packages=find_packages('src'),
+ package_dir={'': 'src'},
+ namespace_packages=['zope'],
+ python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*',
+ extras_require={
+ 'test': TESTS_REQUIRE,
+ 'tal': [
+ 'zope.tal',
+ ],
+ 'docs': [
+ 'Sphinx',
+ 'repoze.sphinx.autointerface',
+ 'zope.tal',
+ ],
+ },
+ install_requires=[
+ 'setuptools',
+ 'zope.interface',
+ 'six',
+ ],
+ tests_require=TESTS_REQUIRE,
+ include_package_data=True,
+ zip_safe=False,
)