summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2014-03-16 06:26:47 -0400
committerJason R. Coombs <jaraco@jaraco.com>2014-03-16 06:26:47 -0400
commit3295ecaed0676556416fe76dfb60ad2348e78cc4 (patch)
tree07f316f158af71ff9262cb2d709ed2ec1413d6fa /setup.py
parent9277828ec3d0d5c899491f29ac30bb6b3595ba65 (diff)
downloadpython-setuptools-bitbucket-3295ecaed0676556416fe76dfb60ad2348e78cc4.tar.gz
Use binary mode to save/restore entry_points - no need to mutate newlines
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 13736be5..19a1dfb7 100755
--- a/setup.py
+++ b/setup.py
@@ -70,7 +70,7 @@ class test(_test):
return # even though _test.run will raise SystemExit
# save the content
- with open(entry_points) as f:
+ with open(entry_points, 'rb') as f:
ep_content = f.read()
# run the test
@@ -78,7 +78,7 @@ class test(_test):
_test.run(self)
finally:
# restore the file
- with open(entry_points, 'w') as f:
+ with open(entry_points, 'wb') as f:
f.write(ep_content)