summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2014-06-15 12:40:55 -0400
committerJason R. Coombs <jaraco@jaraco.com>2014-06-15 12:40:55 -0400
commit9e3a1d2cf6b474895641a4914c09d6127c4ea8a9 (patch)
tree84c2440c8f2eaf56f1cbaac356e07bd5d3399f8d /setup.py
parentd0714625c3ea25a00e8560221617a8ba4fea2d3f (diff)
downloadpython-setuptools-bitbucket-9e3a1d2cf6b474895641a4914c09d6127c4ea8a9.tar.gz
Use io.open for changes file as well to support UTF-8 encoding.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 719a1937..54a86e8b 100755
--- a/setup.py
+++ b/setup.py
@@ -92,10 +92,10 @@ readme_file = io.open('README.txt', encoding='utf-8')
# the release script adds hyperlinks to issues
if os.path.exists('CHANGES (links).txt'):
- changes_file = open('CHANGES (links).txt')
+ changes_file = io.open('CHANGES (links).txt', encoding='utf-8')
else:
# but if the release script has not run, fall back to the source file
- changes_file = open('CHANGES.txt')
+ changes_file = io.open('CHANGES.txt', encoding='utf-8')
with readme_file:
with changes_file:
long_description = readme_file.read() + '\n' + changes_file.read()