summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorJustin Mayer <entroP@gmail.com>2019-11-26 14:03:13 -0800
committerGitHub <noreply@github.com>2019-11-26 14:03:13 -0800
commit772005f431e85abe9e4b09ad5bba9f87fe5a5b5e (patch)
tree4f94f7afa6e983f106323523f748bacafcfcbdf4 /pyproject.toml
parentbae6de5d26646872fedbd00d37a849bba1837a3b (diff)
parent16968834ce9d72e2e51b06ffe16a1c750c224370 (diff)
downloadpelican-772005f431e85abe9e4b09ad5bba9f87fe5a5b5e.tar.gz
Merge pull request #2649 from iKevinY/py2-sunset
Remove Python 2 support
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 2 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 43d17fb1..4d1477c0 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,8 +17,6 @@ classifiers = [
"Framework :: Pelican",
"License :: OSI Approved :: GNU Affero General Public License v3",
"Operating System :: OS Independent",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.5",
"Programming Language :: Python :: 3.6",
@@ -29,7 +27,7 @@ classifiers = [
]
[tool.poetry.dependencies]
-python = "~2.7 || ^3.5"
+python = "^3.5"
feedgenerator = "^1.9"
jinja2 = "~2.10.1"
pygments = "^2.4"
@@ -37,9 +35,8 @@ pytz = "^2019.1"
blinker = "^1.4"
unidecode = "^1.1"
python-dateutil = "^2.8"
-docutils = "^0.14"
+docutils = "^0.15"
markdown = {version = "~3.1.1", optional = true}
-six = "^1.4"
[tool.poetry.dev-dependencies]
BeautifulSoup4 = "^4.7"