summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorxi <xi@18f92427-320e-0410-9341-c67f048884a3>2006-04-23 18:07:52 +0000
committerxi <xi@18f92427-320e-0410-9341-c67f048884a3>2006-04-23 18:07:52 +0000
commit649792a97a294124ea560a455948191ec3f03775 (patch)
tree2e2ab11a60f9653d8364c852c8a6bbbc1d136473 /setup.py
parent89842a44666aea19d544e3a4bad44ceb0f5e47ea (diff)
downloadpyyaml-649792a97a294124ea560a455948191ec3f03775.tar.gz
Prepare setup.py for release. Fix #7.
git-svn-id: http://svn.pyyaml.org/pyyaml/trunk@150 18f92427-320e-0410-9341-c67f048884a3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 33 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e1f12d1..8cdd1ed 100644
--- a/setup.py
+++ b/setup.py
@@ -1,10 +1,35 @@
-NAME = 'PyYAML3000'
-VERSION = '0.1'
-DESCRIPTION = "The next generation YAML parser for Python"
+NAME = 'PyYAML'
+VERSION = '3.0'
+DESCRIPTION = "YAML parser and emitter for Python"
+LONG_DESCRIPTION = """\
+YAML is a data serialization format designed for human readability and
+interaction with scripting languages. PyYAML is a YAML parser and emitter
+for Python.
+
+PyYAML features a complete YAML 1.1 parser, Unicode support, event-based parser
+and emitter (like SAX), API for serializing and deserializing Python objects
+(like DOM or pickle). PyYAML supports all tags from the YAML types repository
+and allows you to extend it easily.
+
+PyYAML is applicable for a broad range of tasks from configuration files to
+object persistance."""
AUTHOR = "Kirill Simonov"
AUTHOR_EMAIL = 'xi@resolvent.net'
LICENSE = "MIT"
+PLATFORMS = "Any"
+URL = "http://pyyaml.org/wiki/PyYAML"
+DOWNLOAD_URL = "http://pyyaml.org/download/pyyaml/%s-%s.tar.gz" % (NAME, VERSION)
+CLASSIFIERS = [
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: Markup",
+]
+
from distutils.core import setup
@@ -12,9 +37,14 @@ setup(
name=NAME,
version=VERSION,
description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
author=AUTHOR,
author_email=AUTHOR_EMAIL,
license=LICENSE,
+ platforms=PLATFORMS,
+ url=URL,
+ download_url=DOWNLOAD_URL,
+ classifiers=CLASSIFIERS,
package_dir={'': 'lib'},
packages=['yaml'],