summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Komissarov <ABBAPOH@gmail.com>2021-03-01 02:42:56 +0100
committerIvan Komissarov <ABBAPOH@gmail.com>2021-03-02 11:48:08 +0000
commit7fc6f8b8a7ac1b6036664da0ed82e23d89e4a03f (patch)
tree6e55fe05f8108dd3d00c15a81f63fa082d3bf594 /CMakeLists.txt
parent14e83c0aa0353446a76e6ca73a152e069f4c9ece (diff)
downloadqbs-7fc6f8b8a7ac1b6036664da0ed82e23d89e4a03f.tar.gz
cmake: add QBS_ENABLE_RPATH option
...required for Brew to switch to CMake - current QMake build explicitly disables RPATH. Also, move all build options to QbsApi.cmake to have them in one place. Change-Id: I97bbfa1de3e34e9dc7a7f8ac4271f47e14ef435e Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f6a87d10d..4088ce9d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,13 +22,6 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-option(WITH_TESTS "Build Tests" ON)
-option(WITH_UNIT_TESTS "Build Unit Tests" OFF)
-option(WITH_PROJECT_FILE_UPDATES "Enable project file updates support" ON)
-option(INSTALL_PUBLIC_HEADERS "Whether to install public headers" ON)
-option(QBS_INSTALL_HTML_DOCS "Whether to install HTML Documentation" OFF)
-option(QBS_INSTALL_QCH_DOCS "Whether to install QCH Documentation" OFF)
-
if(WITH_TESTS)
enable_testing()
set(QT_TEST_COMPONENT Test)