summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Adam <cristian.adam@qt.io>2021-09-15 15:34:01 +0200
committerCristian Adam <cristian.adam@qt.io>2021-09-15 14:26:27 +0000
commit3f0a54d41c5c8eec71d0551df7bd090955988deb (patch)
tree80e5aafd4fb6e8b477f2ff4e6ee1631ee6dc39bb /CMakeLists.txt
parent844cfe70b7eea4508e9b33dad19e5f113ae52a5b (diff)
downloadqt-creator-3f0a54d41c5c8eec71d0551df7bd090955988deb.tar.gz
CMake: Add option to link with Qt
The named option is BUILD_LINK_WITH_QT, which when set to ON will generate the QtCreator.ini file needed for Qt Creator to find the installed Qt. Change-Id: If3a47a463510fbfc90a314829378c6c4e505d2f7 Reviewed-by: Eike Ziller <eike.ziller@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 114a01d9a2..162b0a9aee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,9 @@ set(CMAKE_CXX_EXTENSIONS OFF)
qtc_handle_sccache_support()
+option(BUILD_LINK_WITH_QT "Link with Qt from the parent Qt Creator" OFF)
+qtc_link_with_qt()
+
option(WITH_TESTS "Build Tests" OFF)
add_feature_info("Build tests" ${WITH_TESTS} "")
option(WITH_DEBUG_CMAKE "Enabled CMake project debugging functionality (e.g. source file disk checking)" OFF)