summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2021-02-19 17:35:32 +0100
committerEike Ziller <eike.ziller@qt.io>2021-02-22 07:30:33 +0000
commit7cb81fb5baafa5ebd4c0fcd7bb6856c32c6205f6 (patch)
tree23f0dee912aa77b2348d55944a9855a0fa57643a /CMakeLists.txt
parent2f67d75ca411ab5d4c95dde59e2f0d77a1f80e41 (diff)
downloadqt-creator-7cb81fb5baafa5ebd4c0fcd7bb6856c32c6205f6.tar.gz
CMake build: Add .pri files to development package
This adds at least partial, transitional support for building 3rdparty plugins with qmake against Qt Creator built with CMake. This might still miss some other .pri files that follow their own naming conventions. Fixes: QTCREATORBUG-24055 Fixes: QTCREATORBUG-25334 Change-Id: I83cc547da938976c2ec12a21a17f286b937147f7 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc4b66829a..bb9e4abe05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,25 @@ else()
)
endif()
+# install qmake support files
+install(
+ FILES
+ qtcreator.pri
+ qtcreatordata.pri
+ qtcreator_ide_branding.pri
+ DESTINATION include
+ COMPONENT Devel EXCLUDE_FROM_ALL
+)
+install(
+ FILES
+ src/qtcreatorlibrary.pri
+ src/qtcreatorplugin.pri
+ src/qtcreatortool.pri
+ src/rpath.pri
+ DESTINATION include/src
+ COMPONENT Devel EXCLUDE_FROM_ALL
+)
+
feature_summary(INCLUDE_QUIET_PACKAGES WHAT
PACKAGES_FOUND PACKAGES_NOT_FOUND
ENABLED_FEATURES DISABLED_FEATURES