summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEike Ziller <eike.ziller@qt.io>2022-01-14 12:44:53 +0100
committerEike Ziller <eike.ziller@qt.io>2022-01-20 12:18:15 +0000
commit9d8a419d107ae8219c84bc9178bfed76b94fa930 (patch)
tree110e9f16dd2e3d9c03b2dc38d2b261663606fb4f /CMakeLists.txt
parent3c3580c7701ccf43ca014e19aa5fa210e90b4ed3 (diff)
downloadqt-creator-9d8a419d107ae8219c84bc9178bfed76b94fa930.tar.gz
Remove qmake build files
Removes qmake as a build system for building Qt Creator itself. Keep them for some tests that are not completely moved to CMake yet. Change-Id: I846c6ef65626b6dfae6375fdc85d00677aa8c2fb Reviewed-by: hjk <hjk@qt.io> Reviewed-by: Christian Kandeler <christian.kandeler@qt.io> Reviewed-by: Christian Stenger <christian.stenger@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 0 insertions, 19 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b01bc8f530..c226f78bdb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -175,25 +175,6 @@ else()
)
endif()
-# install qmake support files
-install(
- FILES
- qtcreator.pri
- qtcreatordata.pri
- qtcreator_ide_branding.pri
- DESTINATION ${IDE_HEADER_INSTALL_PATH}
- COMPONENT Devel EXCLUDE_FROM_ALL
-)
-install(
- FILES
- src/qtcreatorlibrary.pri
- src/qtcreatorplugin.pri
- src/qtcreatortool.pri
- src/rpath.pri
- DESTINATION ${IDE_HEADER_INSTALL_PATH}/src
- COMPONENT Devel EXCLUDE_FROM_ALL
-)
-
feature_summary(INCLUDE_QUIET_PACKAGES WHAT
PACKAGES_FOUND PACKAGES_NOT_FOUND
ENABLED_FEATURES DISABLED_FEATURES