summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Krus <mike.krus@kdab.com>2022-05-20 19:31:08 +0100
committerMike Krus <mike.krus@kdab.com>2022-06-03 16:58:46 +0000
commit5729b957a9db727345d6b5f3493791f05f922a88 (patch)
tree4e6cbee6fe55a38291cc13e3b572f9a70466ca82 /CMakeLists.txt
parent9865623145760b015c85209c540259071a173a4e (diff)
downloadqt3d-5729b957a9db727345d6b5f3493791f05f922a88.tar.gz
Fix some compile warnings
Mostly unsafe type conversions, and replacing deprecated APIs. Still can't remove the not-clean-build flags because of bug in qtbase. Pick-to: 6.3 Change-Id: I1e305be2cdf52ccd62949c023c999be347810dd5 Reviewed-by: Paul Lemire <paul.lemire@kdab.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36ed2165b..fb7804a26 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -30,7 +30,7 @@ if(WASM OR NOT QT_FEATURE_opengl)
endif()
# special case begin
-# TODO: Fix warnings and remove this
+# TODO: Fix warnings and remove this (can't remove now because of QTBUG-99248)
set(QT_REPO_NOT_WARNINGS_CLEAN TRUE)
# special case end