summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 15:50:43 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 19:37:01 +0200
commit667dc7b345121e09132a6b4b402d22bd24362338 (patch)
treedc8c2065a59d2ec0c18f535a48aae926a7d225e5 /CMakeLists.txt
parent680b349a1f70a31d35d2a82c9bd31f06872f5bda (diff)
downloadqt3d-667dc7b345121e09132a6b4b402d22bd24362338.tar.gz
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Pick-to: 6.2 Task-number: QTBUG-95018 Change-Id: I29beb4b263c915d3ff5312a3b1ceb45e8fdc34e0 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7714f9926..68c198072 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qt3d.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(Qt3D # special case