summaryrefslogtreecommitdiff
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorJuha Vuolle <juha.vuolle@insta.fi>2022-09-19 12:32:03 +0300
committerJuha Vuolle <juha.vuolle@insta.fi>2022-10-04 07:53:07 +0300
commit46441888164208ed09ce144f3df0ac9713648db8 (patch)
tree83d2b82bbbc871426e16bad40cafbfa91a860883 /tests/auto/CMakeLists.txt
parent3284614452f011b1788f7500e22c297f9c801633 (diff)
downloadqtconnectivity-6.3.tar.gz
Skip few Bluetooth autotests on Android emulator6.3
This is to unblock Android-12 emulator deployment on CI which, unlike the earlier emulators, has a bluetooth emulation. This means that the emulator triggers permission confirmation dialogues which would timeout on CI. This commit replaces the 1ef066bf7d7a67d1b381443b9ecfa60f9204aca8, which attempted to solve the issue by compile-time configuration. Task-number: QTBUG-106614 Change-Id: Idc155bb8617802054d6ab19993f5417cc254f16e Reviewed-by: Assam Boudjelthia <assam.boudjelthia@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> (cherry picked from commit 90251f51be3af2d6db994b92993f2944345e10a6)
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 672a550e..96222438 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,9 +1,4 @@
if(TARGET Qt::Bluetooth)
- if(ANDROID)
- if("$ENV{QTEST_ENVIRONMENT}" STREQUAL "ci")
- add_compile_definitions(ANDROID_CI_TEST_ENVIRONMENT)
- endif()
- endif()
add_subdirectory(qbluetoothaddress)
add_subdirectory(qbluetoothdevicediscoveryagent)
add_subdirectory(qbluetoothdeviceinfo)