summaryrefslogtreecommitdiff
path: root/tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt')
-rw-r--r--tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt b/tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt
index abd84bb8..377e2dd3 100644
--- a/tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt
+++ b/tests/manual/qlowenergycontroller_peripheral/CMakeLists.txt
@@ -37,6 +37,14 @@ else()
QT_ANDROID_BLUETOOTH
)
+ if(MACOS)
+ # Explicitly link against the static permission plugin because tests
+ # currently don't have finalizers run for them except for iOS.
+ # TODO: Remove this when qtbase automatically runs finalizers for tests: QTBUG-112212
+ target_link_libraries(tst_qlowenergycontroller_peripheral
+ PRIVATE Qt6::QDarwinBluetoothPermissionPlugin)
+ endif()
+
endif()
set_target_properties(tst_qlowenergycontroller_peripheral PROPERTIES