summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2022-01-20 17:42:48 +0100
committerKai Köhne <kai.koehne@qt.io>2022-01-24 13:25:13 +0100
commit9d82f4bff8520c3f6db7790d9044c3dfc5cc84c0 (patch)
tree208f1e58e65083c7ddad2abdf1473679176fdaad /examples/CMakeLists.txt
parenta3924b9846f8f3412e6cfc3704f69488e64da98e (diff)
downloadqtdeclarative-9d82f4bff8520c3f6db7790d9044c3dfc5cc84c0.tar.gz
Improve examples CMakeLists.txt
- Remove # generated from xyz.pro comment from pro2cmake - Remove "# special case" markers for pro2cmake - Remove automatic use of CMAKE_AUTORCC - Only opt into CMAKE_AUTOUIC if .ui files are involved - Remove explicit setting of CMAKE_INCLUDE_CURRENT_DIR - Combine multiple find_package(Qt6 ... calls) - use REQUIRED COMPONENTS - sort components alphabetically - Fix wrong indentations - Use (only) one empty line after multi-line commands Pick-to: 6.3 Change-Id: I0d6bfb06c4b25e9921d3d2bf31d977150f12b31b Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Jörg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index d9fabda3c4..86b8aaad1a 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -1,4 +1,4 @@
-find_package(Qt6 COMPONENTS Sql) # special case
+find_package(Qt6 REQUIRED COMPONENTS Sql)
qt_examples_build_begin(EXTERNAL_BUILD)