summaryrefslogtreecommitdiff
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-05-04 12:54:44 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-05-09 21:28:07 +0200
commit41f36038fb2618561b2405efbdaf7ccd5bf3769d (patch)
tree9113b7f00438ec9b77a21e76622275447af6b05c /tools/CMakeLists.txt
parent69bc59c90ff93f8780ee7dba3b00db861e313a05 (diff)
downloadqtdeclarative-41f36038fb2618561b2405efbdaf7ccd5bf3769d.tar.gz
Remove the 'qml-devtools' feature
The meaning of the feature has changed and tools that depends on this feature now need to be built unconditionally. So the feature should be removed to avoid confusing users. [ChangeLog][QtQml][Tools] The 'qml-devtools' feature is removed. All tools that depend on this feature are mandatory and need to be build unconditionally. Fixes: QTBUG-113221 Pick-to: 6.5 Change-Id: Ia026684703d847ce777d7a2916f04b3c90727695 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt26
1 files changed, 12 insertions, 14 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index a99cd33c24..75b240aeea 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -3,21 +3,19 @@
# Generated from tools.pro.
-if(QT_FEATURE_qml_devtools)
- add_subdirectory(qmldom)
- if(QT_FEATURE_commandlineparser)
- add_subdirectory(qmllint)
- add_subdirectory(qmltc)
- add_subdirectory(qmltyperegistrar)
- endif()
- add_subdirectory(qmlimportscanner)
- add_subdirectory(qmlformat)
- if (TARGET Qt::LanguageServerPrivate
- AND NOT WASM AND NOT IOS AND NOT ANDROID AND NOT QNX AND NOT INTEGRITY AND NOT WEBOS)
- add_subdirectory(qmlls)
- endif()
+add_subdirectory(qmldom)
+if(QT_FEATURE_commandlineparser)
+ add_subdirectory(qmllint)
+ add_subdirectory(qmltc)
+ add_subdirectory(qmltyperegistrar)
endif()
-if(QT_FEATURE_qml_devtools AND QT_FEATURE_xmlstreamwriter)
+add_subdirectory(qmlimportscanner)
+add_subdirectory(qmlformat)
+if (TARGET Qt::LanguageServerPrivate
+ AND NOT WASM AND NOT IOS AND NOT ANDROID AND NOT QNX AND NOT INTEGRITY AND NOT WEBOS)
+ add_subdirectory(qmlls)
+endif()
+if(QT_FEATURE_xmlstreamwriter)
# special case begin
# Do not build qmlcachegen here but build it at src/
# time, so that we can use it for our own .qml files in src/imports.