summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 08678b8fc0..7196674a92 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -80,14 +80,12 @@ add_subdirectory(labs)
# These need to be included here since they have dependencies on the modules
# specified above.
-if(QT_FEATURE_qml_devtools)
- add_subdirectory(qmlcompiler)
- add_subdirectory(qmldom)
+add_subdirectory(qmlcompiler)
+add_subdirectory(qmldom)
- # Build qmlcachegen now, so that we can use it in src/imports.
- if(QT_FEATURE_qml_devtools AND QT_FEATURE_xmlstreamwriter)
- add_subdirectory(../tools/qmlcachegen qmlcachegen)
- endif()
+# Build qmlcachegen now, so that we can use it in src/imports.
+if(QT_FEATURE_xmlstreamwriter)
+ add_subdirectory(../tools/qmlcachegen qmlcachegen)
endif()
if(QT_FEATURE_thread AND TARGET Qt::LanguageServerPrivate AND NOT WASM AND NOT IOS AND NOT ANDROID AND NOT QNX AND NOT INTEGRITY AND NOT WEBOS)