summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 16:01:49 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 19:51:30 +0200
commitc401aaa21e11f50368a40453d90faad315303c90 (patch)
treec32a6684c4ad7891745596673b61ef37967ceb57 /CMakeLists.txt
parenta861707c8e6f55f379fb4e58bd9b6c5613745ea0 (diff)
downloadqtdoc-c401aaa21e11f50368a40453d90faad315303c90.tar.gz
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Pick-to: 6.2 Task-number: QTBUG-95018 Change-Id: I23a59d7bfa89ffdacf8002b03657b7da38669ee2 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 869b5bec..9fa6ea7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtdoc.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtDoc # special case