summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorVenugopal Shivashankar <Venugopal.Shivashankar@qt.io>2020-04-30 16:13:46 +0200
committerVenugopal Shivashankar <Venugopal.Shivashankar@qt.io>2020-05-04 23:00:45 +0200
commitde6cc8c379012cd2145fa9cc61b4cc6044fd8c07 (patch)
tree320eac318aa61764acd07b4f62694c99f99c00d6 /doc/CMakeLists.txt
parent9043b57823b291012d1b041a2bc3861b253c1a24 (diff)
downloadqtdoc-de6cc8c379012cd2145fa9cc61b4cc6044fd8c07.tar.gz
CMake: Port the build setup to CMake
Fixes: QTBUG-83910 Change-Id: If0ebd9d0b528cd84ffe92955b7d1c4d580d397fb Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
new file mode 100644
index 00000000..b0fc0b8b
--- /dev/null
+++ b/doc/CMakeLists.txt
@@ -0,0 +1,7 @@
+# special case skip regeneration
+
+add_library(Doc INTERFACE)
+
+qt_add_docs(Doc
+ config/qtdoc.qdocconf
+)