summaryrefslogtreecommitdiff
path: root/examples/demos/clocks/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-05-02 12:32:32 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-02 14:03:48 +0200
commitd02810b25f5b6eeacec1cbe4036c472d38734ed0 (patch)
tree86c04d9296351cf55a63f8eefb1c85ec81e1763d /examples/demos/clocks/CMakeLists.txt
parent835f15cfbb628938fcd7bfa4e334dec6199e54c6 (diff)
downloadqtdoc-d02810b25f5b6eeacec1cbe4036c472d38734ed0.tar.gz
Examples: Use unversioned CMake commands
Prefer unversioned commands over qt6_ ones - even though the target-based qt_add_resources command is actually new in Qt 6. But we will evolve the API also between major Qt versions, so it's better to work with the Qt policies mechanism instead of relying on version numbers in the command API. Pick-to: 6.5 Change-Id: If302abb1f22a7ab96c98a8ad2e9c871b9bedb0e9 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/demos/clocks/CMakeLists.txt')
-rw-r--r--examples/demos/clocks/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/examples/demos/clocks/CMakeLists.txt b/examples/demos/clocks/CMakeLists.txt
index 9fc27be7..428e8cb4 100644
--- a/examples/demos/clocks/CMakeLists.txt
+++ b/examples/demos/clocks/CMakeLists.txt
@@ -45,7 +45,7 @@ set(clocks_resource_files
"content/second.png"
)
-qt6_add_resources(clocks "clocks"
+qt_add_resources(clocks "clocks"
PREFIX
"/demos/clocks"
FILES