summaryrefslogtreecommitdiff
path: root/examples/demos/documentviewer/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAxel Spoerl <axel.spoerl@qt.io>2023-03-23 16:25:43 +0100
committerAxel Spoerl <axel.spoerl@qt.io>2023-05-02 10:11:06 +0200
commitba61af0bf3281cb93a4b8c5ae1410e5015766fa3 (patch)
tree5035c05de869793e37f29335881ecc6fa1f6bbe2 /examples/demos/documentviewer/plugins/CMakeLists.txt
parent58d456c89e789b67c6cb0aee84f5abf4011a74cd (diff)
downloadqtdoc-ba61af0bf3281cb93a4b8c5ae1410e5015766fa3.tar.gz
Migrate documentviewer example into plugin based architecture
This patch changes the document viewer example to a plugin based architecture. It adapts the documentation accordingly. Change-Id: Ia24028aa27e21fb8ab36f5ef3a9953be60858b19 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'examples/demos/documentviewer/plugins/CMakeLists.txt')
-rw-r--r--examples/demos/documentviewer/plugins/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/demos/documentviewer/plugins/CMakeLists.txt b/examples/demos/documentviewer/plugins/CMakeLists.txt
new file mode 100644
index 00000000..60d8b190
--- /dev/null
+++ b/examples/demos/documentviewer/plugins/CMakeLists.txt
@@ -0,0 +1,6 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+add_subdirectory(jsonviewer)
+add_subdirectory(pdfviewer)
+add_subdirectory(txtviewer)