summaryrefslogtreecommitdiff
path: root/examples/demos/samegame/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-05-02 12:25:58 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-02 12:03:42 +0000
commit835f15cfbb628938fcd7bfa4e334dec6199e54c6 (patch)
tree4fe262bce1e25eb99a578097d844440a1454cbc5 /examples/demos/samegame/CMakeLists.txt
parent3705d584d766098dc75fdcc87eb03658ae77be44 (diff)
downloadqtdoc-835f15cfbb628938fcd7bfa4e334dec6199e54c6.tar.gz
Use versioned CMake targets for Qt modules
Use e.g. Qt6::Core instead of Qt::Core. This is better matching the find_package(Qt6 ...) call, and also avoids issues that the versionless targets have. Pick-to: 6.5 Task-number: QTBUG-113277 Change-Id: I9bc7963d8524ef2ab061e32aef428711646247a7 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'examples/demos/samegame/CMakeLists.txt')
-rw-r--r--examples/demos/samegame/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/examples/demos/samegame/CMakeLists.txt b/examples/demos/samegame/CMakeLists.txt
index dd01a09e..79dd0684 100644
--- a/examples/demos/samegame/CMakeLists.txt
+++ b/examples/demos/samegame/CMakeLists.txt
@@ -24,11 +24,11 @@ set_target_properties(samegame PROPERTIES
)
target_link_libraries(samegame PUBLIC
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::Sql
+ Qt6::Core
+ Qt6::Gui
+ Qt6::Qml
+ Qt6::Quick
+ Qt6::Sql
)
# Resources: