summaryrefslogtreecommitdiff
path: root/tests/auto/qml/qqmlparser/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Köhne <kai.koehne@qt.io>2023-05-02 12:25:58 +0200
committerKai Köhne <kai.koehne@qt.io>2023-05-02 12:03:42 +0000
commit835f15cfbb628938fcd7bfa4e334dec6199e54c6 (patch)
tree4fe262bce1e25eb99a578097d844440a1454cbc5 /tests/auto/qml/qqmlparser/CMakeLists.txt
parent3705d584d766098dc75fdcc87eb03658ae77be44 (diff)
downloadqtdoc-835f15cfbb628938fcd7bfa4e334dec6199e54c6.tar.gz
Use versioned CMake targets for Qt modules
Use e.g. Qt6::Core instead of Qt::Core. This is better matching the find_package(Qt6 ...) call, and also avoids issues that the versionless targets have. Pick-to: 6.5 Task-number: QTBUG-113277 Change-Id: I9bc7963d8524ef2ab061e32aef428711646247a7 Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlparser/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlparser/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/auto/qml/qqmlparser/CMakeLists.txt b/tests/auto/qml/qqmlparser/CMakeLists.txt
index 7af990e9..e6f8bca0 100644
--- a/tests/auto/qml/qqmlparser/CMakeLists.txt
+++ b/tests/auto/qml/qqmlparser/CMakeLists.txt
@@ -13,8 +13,8 @@ qt_internal_add_test(tst_qqmlparser_doc # special case
DEFINES
SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}"
LIBRARIES
- Qt::Gui
- Qt::QmlPrivate
+ Qt6::Gui
+ Qt6::QmlPrivate
)
## Scopes: