summaryrefslogtreecommitdiff
path: root/src/effects/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-11-25 18:18:35 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-25 19:38:34 +0100
commitad82815e5a3578aedbc1ded255e6d6b5532f6ded (patch)
treeee23a865c3e8b79f8c178498e6842177bd9c6b81 /src/effects/CMakeLists.txt
parent9d1404ce00464cbd334887abadd3d2ccc8fbe7da (diff)
downloadqtgraphicaleffects-ad82815e5a3578aedbc1ded255e6d6b5532f6ded.tar.gz
CMake: Update project to use latest CMake API
Also make Quick an optional package. Also update qtdeclarative dependency to latest integrated sha1 in qt5.git Change-Id: I851f825abc9484b5bda6cd60eca6ddb1b0d8e2b7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/effects/CMakeLists.txt')
-rw-r--r--src/effects/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/effects/CMakeLists.txt b/src/effects/CMakeLists.txt
index d81355a..cf66a9c 100644
--- a/src/effects/CMakeLists.txt
+++ b/src/effects/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtgraphicaleffectsplugin Plugin:
#####################################################################
-add_qml_module(qtgraphicaleffectsplugin
+qt_internal_add_qml_module(qtgraphicaleffectsplugin
URI "QtGraphicalEffects"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
@@ -47,7 +47,7 @@ set(qtgraphicaleffectsshaders_resource_files
"shaders_ng/thresholdmask.frag.qsb"
)
-add_qt_resource(qtgraphicaleffectsplugin "qtgraphicaleffectsshaders"
+qt_internal_add_resource(qtgraphicaleffectsplugin "qtgraphicaleffectsshaders"
PREFIX
"/qt-project.org/imports/QtGraphicalEffects"
FILES
@@ -136,7 +136,7 @@ qt6_target_qml_files(qtgraphicaleffectsplugin
FILES
${qml_files}
)
-add_qt_docs(qtgraphicaleffectsplugin
+qt_internal_add_docs(qtgraphicaleffectsplugin
doc/qtgraphicaleffects.qdocconf
)