summaryrefslogtreecommitdiff
path: root/src/effects/private/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-11-25 18:18:35 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-25 19:38:34 +0100
commitad82815e5a3578aedbc1ded255e6d6b5532f6ded (patch)
treeee23a865c3e8b79f8c178498e6842177bd9c6b81 /src/effects/private/CMakeLists.txt
parent9d1404ce00464cbd334887abadd3d2ccc8fbe7da (diff)
downloadqtgraphicaleffects-ad82815e5a3578aedbc1ded255e6d6b5532f6ded.tar.gz
CMake: Update project to use latest CMake API
Also make Quick an optional package. Also update qtdeclarative dependency to latest integrated sha1 in qt5.git Change-Id: I851f825abc9484b5bda6cd60eca6ddb1b0d8e2b7 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/effects/private/CMakeLists.txt')
-rw-r--r--src/effects/private/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/effects/private/CMakeLists.txt b/src/effects/private/CMakeLists.txt
index a75eda4..b8e0e5b 100644
--- a/src/effects/private/CMakeLists.txt
+++ b/src/effects/private/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtgraphicaleffectsprivate Plugin:
#####################################################################
-qt_add_qml_module(qtgraphicaleffectsprivate
+qt_internal_add_qml_module(qtgraphicaleffectsprivate
URI "QtGraphicalEffects.private"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtGraphicalEffectsPrivatePlugin