summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 14:07:17 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-10-15 12:23:59 +0000
commit36c362412b8829c61a1292c654a7d9e2a8c290e9 (patch)
tree60c487eab6e24571eb7ceeffd9e7ddf90d9e2a3d /CMakeLists.txt
parent1d4a58a877b8b28074ca84a07340d2d8604b38d6 (diff)
downloadqtimageformats-36c362412b8829c61a1292c654a7d9e2a8c290e9.tar.gz
Regenerate projects before merge
Change-Id: I9a889214e310b95ca1418925d6413602f9e00cea Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 561fc11..961585c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,18 @@
+# Generated from qtimageformats.pro.
+
cmake_minimum_required(VERSION 3.15.0)
-project(QtImageFormats
+project(QtImageFormats # special case
VERSION 6.0.0
- DESCRIPTION "Qt ImageFormats Libraries"
+ DESCRIPTION "Qt ImageFormats Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Gui)
-qt_build_repo()
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Gui) # special case
+if(NOT TARGET Qt::Gui)
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
+ return()
+endif()
+qt_build_repo()