summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-08 15:40:56 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2023-02-08 16:20:50 +0100
commit93ece87be2bf7a8e905e1b462ae7705280603a27 (patch)
tree3787d005a6cc6e2649dd203e22267b8a8c9678e7 /CMakeLists.txt
parentd7f26f37179a245f33c8f39dfbc15bccf65913f5 (diff)
downloadqtimageformats-93ece87be2bf7a8e905e1b462ae7705280603a27.tar.gz
Remove remains of qmake conversion from CMakeLists.txt files
Pick-to: 6.5 Change-Id: Ic00df7d45246270d724b3b1d1ef9d13d76dcc136 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 947a5f3..684482d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,20 +1,18 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from qtimageformats.pro.
-
cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
-project(QtImageFormats # special case
+project(QtImageFormats
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt ImageFormats Libraries" # special case
+ DESCRIPTION "Qt ImageFormats Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui)
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()