summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-17 19:13:24 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-28 12:50:42 +0000
commit9443239c2c01810189d63854393d43c493201c66 (patch)
tree017d1c7f31f12dfd420c064f3032b408e17a342c /CMakeLists.txt
parent9a4a2dd5189e1659bce46eacef513b0c5680bb1e (diff)
downloadqtimageformats-9443239c2c01810189d63854393d43c493201c66.tar.gz
Initial CMake Port
Port 90% of imageformats to be built with CMake. Missing support for mng plugin and documentation. Change-Id: I1d7e4b93c6f8446468f00dbf0663a6a4ec8c9774 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..f286284
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.14.0)
+
+project(QtImageFormats
+ VERSION 5.14.0
+ DESCRIPTION "Qt ImageFormats Libraries"
+ HOMEPAGE_URL "https://qt.io/"
+ LANGUAGES CXX C
+)
+
+find_package(Qt5 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Gui)
+qt_build_repo()
+