summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-14 20:08:23 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-21 14:05:44 +0200
commitaf068aada2b3f186bb29180d2a879070d804d6fd (patch)
treeb4325d2810fc610e385ae255b48213ba6a2e1340 /CMakeLists.txt
parentf4038064f097fcc47068d3cab5c1a611f72b6cf0 (diff)
downloadqtimageformats-af068aada2b3f186bb29180d2a879070d804d6fd.tar.gz
Use fixed qt_add_resource BASE argument
Pick-to: 6.1 Task-number: QTBUG-86726 Change-Id: I7457f9336915e5913c6c98053db979eb9ca197a5 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4936922..46e457d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,9 @@ project(QtImageFormats # special case
# special case begin
# Make sure we only use latest private CMake API, aka no compatibility wrappers.
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
+# Make sure we use the fixed BASE argument of qt_add_resource.
+set(QT_USE_FIXED_QT_ADD_RESOURCE_BASE TRUE)
# special case end
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case