summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEirik Aavitsland <eirik.aavitsland@qt.io>2020-11-24 11:28:17 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2020-12-10 11:34:20 +0000
commitcd270555d650d78ce2ab2fd84c11ed8ddcd3c14d (patch)
tree979cb3fff3b0405133dd9efb0b66c48e92c1c686 /CMakeLists.txt
parent46491ab360a6eb99766f01d7530b9fb335a1e128 (diff)
downloadqtimageformats-cd270555d650d78ce2ab2fd84c11ed8ddcd3c14d.tar.gz
Ensure clean exit from configure in case of no-gui build
Fixes: QTBUG-88734 Change-Id: Ib2630658085d12de0151365fccf8e3ae9546c562 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io> (cherry picked from commit 7ee2148f24c49ce23db53e1e5b1672d9b4d86f46) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b419fc9..4936922 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,8 +15,8 @@ project(QtImageFormats # special case
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
# special case end
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Gui) # special case
-
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
+find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui) # special case
if(NOT TARGET Qt::Gui)
message(NOTICE "Skipping the build as the condition \"TARGET Qt::Gui\" is not met.")
return()