summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 15:44:23 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 19:36:56 +0200
commitf3a43f120bb6e371dcf7fead58b02bd013ff7251 (patch)
tree030aa70a2811c795795ae2ff26ec176e69087698 /CMakeLists.txt
parentba5b3fdaef48c398dd8d23a2c92aee33b109e37a (diff)
downloadqtimageformats-f3a43f120bb6e371dcf7fead58b02bd013ff7251.tar.gz
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Pick-to: 6.2 Task-number: QTBUG-95018 Change-Id: Ide716d1d11dffd18d43c5eb67d41699ef986d138 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e81948d..47694d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
# Generated from qtimageformats.pro.
-cmake_minimum_required(VERSION 3.15.0)
+cmake_minimum_required(VERSION 3.16)
include(.cmake.conf)
project(QtImageFormats # special case