summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 17:07:41 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 18:02:19 +0000
commitc96422ae949b151399be50d606cc40ecfb7e6ddb (patch)
tree688ff72b94eb67d6c0a3d164947c3f040843cdcd /tests/CMakeLists.txt
parent51e7fa714ca76fd9edb342fc8e97451086e46fe3 (diff)
downloadqtimageformats-c96422ae949b151399be50d606cc40ecfb7e6ddb.tar.gz
CMake: Regenerate and fixup qtimageformats projectswip/cmake
A few changes happened since last update: - CMake target names are now consistent with Qt 5 names - ZLIB handling - TIFF 3rd party handling - Standalone tests simplification - Updates in the SUBDIRS project - Other minor changes Change-Id: I85cca79d38feca44c5b78dae48c79779ae05e288 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 5a389d6..2214137 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,10 +1,7 @@
# Generated from tests.pro.
-if(NOT TARGET Qt::Test)
- cmake_minimum_required(VERSION 3.15.0)
- project(imageformatsTests_FIXME VERSION 6.0.0 LANGUAGES C CXX)
- find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Test) # special case
- find_package(Qt6 ${PROJECT_VERSION} OPTIONAL_COMPONENTS Gui) # special case
- qt_set_up_standalone_tests_build()
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
endif()
qt_build_tests()