summaryrefslogtreecommitdiff
path: root/tests/auto/heif/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/heif/CMakeLists.txt')
-rw-r--r--tests/auto/heif/CMakeLists.txt23
1 files changed, 18 insertions, 5 deletions
diff --git a/tests/auto/heif/CMakeLists.txt b/tests/auto/heif/CMakeLists.txt
index 0412996..c40e1f7 100644
--- a/tests/auto/heif/CMakeLists.txt
+++ b/tests/auto/heif/CMakeLists.txt
@@ -12,10 +12,23 @@ add_qt_test(tst_qheif
)
# Resources:
-add_qt_resource(tst_qheif "heif" PREFIX "/" BASE "../../shared/images" FILES
- heif/col320x480.heic
- heif/newlogoCCW.heic)
+set_source_files_properties("../../shared/images/heif/col320x480.heic"
+ PROPERTIES QT_RESOURCE_ALIAS "heif/col320x480.heic"
+)
+set_source_files_properties("../../shared/images/heif/newlogoCCW.heic"
+ PROPERTIES QT_RESOURCE_ALIAS "heif/newlogoCCW.heic"
+)
+set(heif_resource_files
+ "heif/col320x480.heic"
+ "heif/newlogoCCW.heic"
+)
+add_qt_resource(tst_qheif "heif"
+ PREFIX
+ "/"
+ BASE
+ "../../shared/images"
+ FILES
+ ${heif_resource_files}
+)
-#### Keys ignored in scope 1:.:.:heif.pro:<TRUE>:
-# CONFIG = "-app_bundle" "testcase"