summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-05-26 10:30:58 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-26 18:05:01 +0200
commit9ff40ad1b2376e66a1af81fb8cd5b7991820d00a (patch)
tree25c4e11adceafa327a62899bb76bcd838558e840 /CMakeLists.txt
parent6a14fc6172f687fbbbc6a5a5d0df081508fd2d41 (diff)
downloadqtivi-9ff40ad1b2376e66a1af81fb8cd5b7991820d00a.tar.gz
Make the ivicore examples to be fully functional again
* Generation of QML Plugins fixed to work out of the box * Use correct folder structure for executables and plugins * Add optional DBus dependency for qface-tutorial * Remove the shader-effect from the qface-tutorial Change-Id: I212eade621ac9d741e1f0fe75ceef2c59c312865 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b004f9c..9decfec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,7 @@ project(QtIvi
set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Qml Quick RemoteObjects Multimedia Sql) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Qml Quick RemoteObjects Multimedia Sql DBus) # special case
include(src/ivicore/Qt6IviCoreMacros.cmake)