summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 15:14:38 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-26 12:11:07 +0200
commitf357bb6e64ea24e4ec27b6d84c94c3a6dadc24fa (patch)
treef8fe67b7ea4e609f0f16ddcdbed5c636f9bd5966 /CMakeLists.txt
parentc09bcfbdf0232f8b827fc2a4dd19ca433a62df5f (diff)
downloadqtivi-f357bb6e64ea24e4ec27b6d84c94c3a6dadc24fa.tar.gz
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I7f86da0411b4870b1a9f9e1ed0b63cf30ccd48ad Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa98ae7..b004f9c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,9 @@ project(QtIvi
LANGUAGES CXX C
)
+# Make sure we only use latest private CMake API, aka no compatibility wrappers.
+set(QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS TRUE)
+
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core) # special case
find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Gui Qml Quick RemoteObjects Multimedia Sql) # special case