summaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2020-11-17 12:27:36 +0100
committerDominik Holland <dominik.holland@qt.io>2021-03-26 11:02:46 +0100
commit3fdd3573f716b044824e11dcd1cabb8442ffeea8 (patch)
tree4f39b967a2aa2ee23daf70bc5ab6d83c1bfb862c /examples/CMakeLists.txt
parent9516ab95f0aac46df99323f3f8d1d7c5ac38365a (diff)
downloadqtivi-3fdd3573f716b044824e11dcd1cabb8442ffeea8.tar.gz
cmake: Start of cmake port using run_pro2cmake.py and friends
Some special cases are already addressed. Task-number: AUTOSUITE-1633 Change-Id: I5409522c1c5eb76b8aac3e7e332d1e1cc27e594f Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 0000000..5454d68
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Generated from examples.pro.
+
+qt_examples_build_begin()
+
+if(TARGET Qt::Gui AND TARGET Qt::IviCore)
+ add_subdirectory(ivicore)
+endif()
+if(TARGET Qt::Gui AND TARGET ivivehiclefunctions)
+ add_subdirectory(ivivehiclefunctions)
+endif()
+if(TARGET Qt::Gui AND TARGET Qt::IviMedia)
+ add_subdirectory(ivimedia)
+endif()
+if(TARGET geniviextras)
+ add_subdirectory(geniviextras)
+endif()
+
+qt_examples_build_end()