summaryrefslogtreecommitdiff
path: root/examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-05-26 10:30:58 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-26 18:05:01 +0200
commit9ff40ad1b2376e66a1af81fb8cd5b7991820d00a (patch)
tree25c4e11adceafa327a62899bb76bcd838558e840 /examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt
parent6a14fc6172f687fbbbc6a5a5d0df081508fd2d41 (diff)
downloadqtivi-9ff40ad1b2376e66a1af81fb8cd5b7991820d00a.tar.gz
Make the ivicore examples to be fully functional again
* Generation of QML Plugins fixed to work out of the box * Use correct folder structure for executables and plugins * Add optional DBus dependency for qface-tutorial * Remove the shader-effect from the qface-tutorial Change-Id: I212eade621ac9d741e1f0fe75ceef2c59c312865 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt
index 7be44e4..710ee4d 100644
--- a/examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/CMakeLists.txt
@@ -1,4 +1,6 @@
# Generated from chapter3-simulation-backend.pro.
+cmake_minimum_required(VERSION 3.14)
+project(qface-chapter3-simulation-backend LANGUAGES CXX)
add_subdirectory(instrument-cluster)
add_subdirectory(frontend)