summaryrefslogtreecommitdiff
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2020-11-17 12:27:36 +0100
committerDominik Holland <dominik.holland@qt.io>2021-03-26 11:02:46 +0100
commit3fdd3573f716b044824e11dcd1cabb8442ffeea8 (patch)
tree4f39b967a2aa2ee23daf70bc5ab6d83c1bfb862c /tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
parent9516ab95f0aac46df99323f3f8d1d7c5ac38365a (diff)
downloadqtivi-3fdd3573f716b044824e11dcd1cabb8442ffeea8.tar.gz
cmake: Start of cmake port using run_pro2cmake.py and friends
Some special cases are already addressed. Task-number: AUTOSUITE-1633 Change-Id: I5409522c1c5eb76b8aac3e7e332d1e1cc27e594f Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
new file mode 100644
index 0000000..985b371
--- /dev/null
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-qtro/server_qtro_test/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from server_qtro_test.pro.
+
+#####################################################################
+## tst_org-example-echo-qtro Test:
+#####################################################################
+
+qt_add_test(tst_org-example-echo-qtro
+ OUTPUT_DIRECTORY ".."
+ SOURCES
+ contactsmodelservice.cpp contactsmodelservice.h
+ echoservice.cpp echoservice.h
+ echozonedservice.cpp echozonedservice.h
+ main.cpp
+ server.cpp server.h
+ tst_echoqtro.cpp tst_echoqtro.h
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_BINARY_DIR}/../backend_qtro
+ ${CMAKE_CURRENT_BINARY_DIR}/../frontend
+ PUBLIC_LIBRARIES
+ # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
+ Qt::IviCore
+ iviremoteobjects_helper_private
+)
+
+#### Keys ignored in scope 1:.:.:server_qtro_test.pro:<TRUE>:
+# QFACE_FORMAT = "server_qtro"
+# QFACE_SOURCES = "../../../org.example.echo.qface"
+# QMAKE_PROJECT_NAME = "$$TARGET"
+# QMAKE_RPATHDIR = "$$OUT_PWD/.." "$$OUT_PWD/../qtivi"