summaryrefslogtreecommitdiff
path: root/examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt20
1 files changed, 5 insertions, 15 deletions
diff --git a/examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt b/examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt
index 90ec5d8..497c040 100644
--- a/examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt
+++ b/examples/ivicore/qface-ivi-remote/backend_qtro/CMakeLists.txt
@@ -1,8 +1,4 @@
# Generated from backend_qtro.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(example_ivi_remote LANGUAGES CXX)
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
@@ -19,29 +15,23 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS IviCore)
-qt_add_plugin(example_ivi_remote)
+qt_add_plugin(remote_backend_qtro)
+set_target_properties(remote_backend_qtro PROPERTIES LIBRARY_OUTPUT_DIRECTORY ../qtivi)
# IVI Generator:
-qt6_ivigenerator(example_ivi_remote
+qt6_ivigenerator(remote_backend_qtro
QFACE_SOURCES ../example-ivi-remote.qface
QFACE_FORMAT backend_qtro
)
-set_target_properties(example_ivi_remote PROPERTIES
- WIN32_EXECUTABLE TRUE
- MACOSX_BUNDLE TRUE
-)
-target_include_directories(example_ivi_remote PUBLIC
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
-)
-target_link_libraries(example_ivi_remote PUBLIC
+target_link_libraries(remote_backend_qtro PUBLIC
QtIviRemoteExample
Qt::Core
Qt::Gui
Qt::IviCore
)
-install(TARGETS example_ivi_remote
+install(TARGETS remote_backend_qtro
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"