summaryrefslogtreecommitdiff
path: root/examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt
index 40ea623..7ff6cab 100644
--- a/examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter2-enums-structs/instrument-cluster/CMakeLists.txt
@@ -1,8 +1,4 @@
# Generated from instrument-cluster.pro.
-
-cmake_minimum_required(VERSION 3.14)
-project(chapter2-enums-structs LANGUAGES CXX)
-
set(CMAKE_INCLUDE_CURRENT_DIR ON)
set(CMAKE_AUTOMOC ON)
@@ -23,13 +19,11 @@ find_package(Qt6 COMPONENTS Quick)
qt_add_executable(chapter2-enums-structs
main.cpp
)
+set_target_properties(chapter2-enums-structs PROPERTIES RUNTIME_OUTPUT_DIRECTORY ../)
set_target_properties(chapter2-enums-structs PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE FALSE
)
-target_include_directories(chapter2-enums-structs PUBLIC
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
-)
target_link_libraries(chapter2-enums-structs PUBLIC
QtIviInstrumentCluster_Chapter2