summaryrefslogtreecommitdiff
path: root/tests/baseline/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/baseline/CMakeLists.txt')
-rw-r--r--tests/baseline/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/baseline/CMakeLists.txt b/tests/baseline/CMakeLists.txt
new file mode 100644
index 00000000..f38e01c3
--- /dev/null
+++ b/tests/baseline/CMakeLists.txt
@@ -0,0 +1,7 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+# Special case: test includes the QBaselineTest module sources from qtbase directly
+if(EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/../../../qtbase/tests/baseline/shared")
+ add_subdirectory(mapitems)
+endif()