summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2020-11-18 17:10:56 +0100
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-11-19 12:24:32 +0100
commit0061dc700f4b95a105039bab82948dbe03870339 (patch)
tree2a244b1cee1382f398ed4f01a5b817aab91cd8a2 /CMakeLists.txt
parent76340371c58c16ca39d80cfd2ceddf2d0479df79 (diff)
downloadqtqa-0061dc700f4b95a105039bab82948dbe03870339.tar.gz
CMake: Use QT_BUILD_TESTS_BY_DEFAULT
...instead of the removed QT_NO_MAKE_TESTS. Change-Id: Ic7764e4111dd1d0b640c2430ba77f8d9a8071413 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b500b4..aaaeabb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,7 +25,7 @@ if(BUILD_TESTING)
add_subdirectory(scripts)
add_subdirectory(tests)
- if(QT_NO_MAKE_TESTS)
+ if(NOT QT_BUILD_TESTS_BY_DEFAULT)
set_property(DIRECTORY scripts PROPERTY EXCLUDE_FROM_ALL TRUE)
set_property(DIRECTORY tests PROPERTY EXCLUDE_FROM_ALL TRUE)
endif()