summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-14 18:19:34 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-06-02 20:10:57 +0200
commit81e3c42381bd7def1abe9c4486981bc544b759cc (patch)
tree2f1afef48d744d6ac26445f4a8396a6e871f027d /scripts/CMakeLists.txt
parent354c7577188cfffd417fd973b8611d84174eba85 (diff)
downloadqtqa-81e3c42381bd7def1abe9c4486981bc544b759cc.tar.gz
CMake: Port qtqa to CMake
Some parts were not ported because they were deemed unnecessary for now. This includes the scripts directory (which has a bunch perl scripts wrapped in qmake make targets), and the tests/prebuild directory which only has the perl license checking script. The following 3 projects were made standalone buildable, to support the same use case that Coin does with qmake (calling qmake directly on those projects), even though some of them might not be necessary anymore: scripts, tests, tests/postbuild/bic (arguably the only one needed). Task-number: QTBUG-84233 Change-Id: I6f151f9044a61f4ddbd029351c5ebf225f1bf82d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
new file mode 100644
index 0000000..600ac4b
--- /dev/null
+++ b/scripts/CMakeLists.txt
@@ -0,0 +1,8 @@
+# special case skip regeneration
+# scripts.pro and children projects are not ported yet.
+# If the need arises, it can be done.
+# The empty file exists only for the purpose of mimicking the
+# Coin qmake instructins, where qmake is executed directly on the
+# scripts.pro folder. Hence the same should be possible for CMake.
+cmake_minimum_required(VERSION 3.15)
+project(QtQualityAssuranceScripts)