summaryrefslogtreecommitdiff
path: root/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 16:09:20 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-09-22 19:51:35 +0200
commitbc186f6af18512e76317a7fddefb7b6a137ed55d (patch)
tree82fb41fad50ed3316b4779f22cc58b4ff84fb29c /scripts/CMakeLists.txt
parent87336e3e43ae8c363273bfd7b0fb94cb59644015 (diff)
downloadqtqa-bc186f6af18512e76317a7fddefb7b6a137ed55d.tar.gz
CMake: Bump almost all cmake_minimum_required calls to 3.16
Needed for subsequent change that will check and error out if the version is lower than 3.16. We do that to ensure all policies introduced by CMake up to version 3.16 have their behavior set to NEW. Task-number: QTBUG-95018 Change-Id: I446c17472d8771d075ab1e54f48a52942883fa2f Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Kai Koehne <kai.koehne@qt.io>
Diffstat (limited to 'scripts/CMakeLists.txt')
-rw-r--r--scripts/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/CMakeLists.txt b/scripts/CMakeLists.txt
index 600ac4b..f1cc4ee 100644
--- a/scripts/CMakeLists.txt
+++ b/scripts/CMakeLists.txt
@@ -4,5 +4,5 @@
# The empty file exists only for the purpose of mimicking the
# Coin qmake instructins, where qmake is executed directly on the
# scripts.pro folder. Hence the same should be possible for CMake.
-cmake_minimum_required(VERSION 3.15)
+cmake_minimum_required(VERSION 3.16)
project(QtQualityAssuranceScripts)