summaryrefslogtreecommitdiff
path: root/examples/serialport/terminal/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/serialport/terminal/CMakeLists.txt')
-rw-r--r--examples/serialport/terminal/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/examples/serialport/terminal/CMakeLists.txt b/examples/serialport/terminal/CMakeLists.txt
index 4a5a3d4..e430780 100644
--- a/examples/serialport/terminal/CMakeLists.txt
+++ b/examples/serialport/terminal/CMakeLists.txt
@@ -4,9 +4,6 @@
cmake_minimum_required(VERSION 3.16)
project(terminal LANGUAGES CXX)
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTOUIC ON)
-
if(NOT DEFINED INSTALL_EXAMPLESDIR)
set(INSTALL_EXAMPLESDIR "examples")
endif()
@@ -15,6 +12,8 @@ set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/serialport/terminal")
find_package(Qt6 REQUIRED COMPONENTS Core Gui SerialPort Widgets)
+qt_standard_project_setup()
+
qt_add_executable(terminal
console.cpp console.h
main.cpp
@@ -43,7 +42,7 @@ set(terminal_resource_files
"images/settings.png"
)
-qt6_add_resources(terminal "terminal"
+qt_add_resources(terminal "terminal"
PREFIX
"/"
FILES