summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-07-03 15:30:42 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-07-03 14:23:03 +0000
commitbacfc218112b2aab7ab2119028b23ecaca391995 (patch)
treecd7c84817e36131266c52b0937d85c5f676853e7 /CMakeLists.txt
parentb674c81225bd5f83b247b085f98879a4b7d24252 (diff)
downloadqtsvg-bacfc218112b2aab7ab2119028b23ecaca391995.tar.gz
Search for Xml package and check for the Xml target for a test
This fixes the CMake configuration to succeed if the Xml package is not built. Change-Id: I062ef1dc70c3eef286eaadb62a5fe6b7c827f3db Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8004d78..ce44afe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,4 +8,5 @@ project(QtSvg
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG COMPONENTS Xml) # For tests
qt_build_repo()