summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d78b2db..7b8f368 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,14 @@
+# Generated from qtsvg.pro.
+
cmake_minimum_required(VERSION 3.15.0)
project(QtSvg
VERSION 6.0.0
- DESCRIPTION "Qt SVG Libraries"
+ DESCRIPTION "Qt SVG Libraries" # special case
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG COMPONENTS Xml) # For tests
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core Gui Widgets) # special case
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Xml) # special case for tests
qt_build_repo()