summaryrefslogtreecommitdiff
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 654a7d4..4d32595 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,7 +1,13 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
-# Generated from auto.pro.
+# For now, don't built auto tests when QT_BUILD_MINIMAL_STATIC_TEST
+# is specified and the build is targeting iOS. QT_BUILD_MINIMAL_STATIC_TEST is used in our CI.
+# Regular non-cmake build tests shouldn't be built because the CI will try to run them and fail
+# due to missing simulator support.
+if(IOS AND QT_BUILD_MINIMAL_STATIC_TESTS)
+ return()
+endif()
if(TARGET Qt::Widgets)
add_subdirectory(qsvgdevice)